Page 2 of 2 FirstFirst 12
Results 26 to 42 of 42

Thread: [EXTREME PRIORITY] [POSSIBLE FIX] blue screen on Linux launch

  1. #26
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    Light the fireworks!!! The distro update helped. I'm on 16.04 now an the game starts (although everything is really dark, but thats an other story).

    So I guess this could be considered as resolved or if you want to figure out why it didn't work on 14.04, the priority could be lowered at least.

    Now, I'll go and fix some other stuff, what the upgrade screwed up

  2. #27
    Super Moderator Wazbat's Avatar
    Join Date
    Jun 2015
    Posts
    395
    Post Thanks / Like
    Quote Originally Posted by fura View Post
    Light the fireworks!!! The distro update helped. I'm on 16.04 now an the game starts (although everything is really dark, but thats an other story).
    Noice! I believe the brightness errors are resolved for the next update. I think it had something to do with locale errors.
    I'll leave this thread open incase updating doesn't fix it for them

  3. #28
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    Quote Originally Posted by Wazbat View Post
    Noice! I believe the brightness errors are resolved for the next update. I think it had something to do with locale errors.
    I'll leave this thread open incase updating doesn't fix it for them
    Yeah, brightness errors are surely related to locale settings. I tried to change it to en_US, that fixed the brightness, but made some textures flickery white. I read in an other thread that this is already solved and fix fill come with the next update.

  4. #29
    Preorder Collector Nomad
    Join Date
    Aug 2016
    Posts
    22
    Post Thanks / Like
    @fura In addition to verifying the libraries & installing 2 missing ones we also discovered that the sqlite3 was missing and installed that as well. Don't remember which of the libraries on the list were missing but after going through all of them and putting in the missing ones plus sqlite3 it didn't work until after a reboot. Didn't end up using any launch params in the end.

    As a side note on 14.04 -> 16.04 when we put that upgrade in a while back the upgrade didn't take and had to wipe the system and install fresh from a downloaded iso of Ubuntu.

  5. #30
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    Quote Originally Posted by TrinityC View Post
    @fura In addition to verifying the libraries & installing 2 missing ones we also discovered that the sqlite3 was missing and installed that as well. Don't remember which of the libraries on the list were missing but after going through all of them and putting in the missing ones plus sqlite3 it didn't work until after a reboot. Didn't end up using any launch params in the end.
    It seems it wasn't related to sqlite eventually. I also had to install a missing lib, but that didn't do the trick even after rebooting. Maybe I missed something. I'm not really a Linux pro

    I'm using a launch param now because of a known issue related to the regional settings.

    Quote Originally Posted by TrinityC View Post
    As a side note on 14.04 -> 16.04 when we put that upgrade in a while back the upgrade didn't take and had to wipe the system and install fresh from a downloaded iso of Ubuntu.
    It seems so far that it didn't mess up anything serious, only minor things. Eventually I'll do a clean install - like I planned originally - but that needs some preparations

  6. #31
    Preorder Collector Nomad
    Join Date
    Aug 2016
    Posts
    22
    Post Thanks / Like
    Quote Originally Posted by fura View Post
    It seems it wasn't related to sqlite eventually. I also had to install a missing lib, but that didn't do the trick even after rebooting. Maybe I missed something. I'm not really a Linux pro
    I'm not a linux pro either. You don't want to know how long I spent googling each line... until I found something for each one that worked. Some things I'm ok at, but the best trick I've found is searching again and again


    Quote Originally Posted by fura View Post
    It seems so far that it didn't mess up anything serious, only minor things. Eventually I'll do a clean install - like I planned originally - but that needs some preparations
    You got luckier than me then Good luck when the time comes

  7. #32
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    OMFG, I just realized that fglrx driver is deprecated, not part of 16.04. And AMD adds 16.04 support only for the freakin' RX series drivers... And I have an R9 270x...

    And I see a non-negligible chance that the flickery white texture issue is caused by the current graphics diver

  8. #33
    Kickstarter Alpha Nomad
    Join Date
    Aug 2016
    Posts
    4
    Post Thanks / Like
    Good luck, @Fura!

  9. #34
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    So white flickery patches seems to be related to lighting and shadows. I found in an other thread that adding -force-opengl as launch param gets rid of the white patches. And it does indeed.

    So although I'm not really happy with the current driver (because of other issues), the game runs pretty smooth now. Best is, that there is no sign of the memory issue, which the Windows build has, so I can drive around as fast as I can, as far as I want without crashing

  10. #35
    Kickstarter Alpha Nomad
    Join Date
    Aug 2016
    Location
    Republic Of Texas
    Posts
    7
    Post Thanks / Like
    I was going to say,
    Ubi 16.4 dont play nice with ATI FGLRX, so that would in theory cause more problems than it should solve.

    I too have the ATI R9270x and cant get PlanetNomads to start in my MINT17,
    and I cant get STEAM to start at all in my other partition MINT18

    Should I consider this an extension of the linux start problem in this thread,
    or start a new thread with my Linux Fail To Start?


    Video
    : ati r9270x
    OS: Mint17
    Drivers:
    FLGRX from ati: CCC Reports 15.201.1151-150908a
    OpenGL compatability 4.5.13399
    CRASH: Try start game (Steam / Desktop / terminal), Unity Splash screen works, then it trys and fails to open a blue screen.
    Linux Steam & OpenGL work ok- benchmark Haven & Valley ok, and steam plays WarThunder just fine

    I have room on my disk for installing another fresh Linux partition,
    what Linux ver should I try,
    and which drivers for ATI R9270x... since the new Xorg system generally dont play nice with FLGRX drivers?

  11. #36
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    Right now even playing an SD video causes terrible vsync, so 16.04 seems to be a no go... After doing some research on the driver issues, I don't think clean installing it would help. Most of the recommendations are to stay on 14.04, also seems that AMD won't make a driver for this card.

    I'm planning to do a clean install of 14.04. I think I missed something while verifying the libs. This seems to be the best option for me.

  12. #37
    Kickstarter Alpha Nomad
    Join Date
    Aug 2016
    Posts
    229
    Post Thanks / Like
    Arch linux kicked the amd drivers from the official repos because they were always outdated, but there is a custom repo with older xorg and stuff for people that want to use amd binary driver.
    You could also use the open driver, afaik they catched up recently. - https://wiki.archlinux.org/index.php/ATI
    100% linux gaming

  13. #38
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    Well, it seems I'm back at the beginning. I've downgraded to 14.04, because 16.04 was just a mess in regards of graphics. Now everything runs fine, except from PN, which fails with the blue screen again...

  14. #39
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    So I'm wondering if I'm the only one stuck with this issue? The open source drivers are not really an option because it causes terrible vsync issues in everything basically. And it seems fglrx and Unity doesn't really like each other :/

  15. #40
    Kickstarter Alpha Nomad
    Join Date
    Aug 2016
    Location
    Republic Of Texas
    Posts
    7
    Post Thanks / Like
    To get around the AMD card problem
    i gave up on AMD.

    I bought an older nvidia GTX 750-ti from amazon, and put that in a fresh linux MINT18. Using mint menu proprietary driver (361). Working ok, and decent framerate, but getting some odd lighting... but that may be the game (in alpha) and not the card & driver fault.

  16. #41
    Kickstarter Nomad Xen0sys's Avatar
    Join Date
    Feb 2016
    Posts
    3
    Post Thanks / Like
    Wanted to at least provide some information that may help. Best bet with AMD is to use the latest of everything (OS, Kernel, Mesa): https://www.phoronix.com/scan.php?pa...y-amdmay&num=1

    OS: 17.04+
    Kernel: 4.11+
    Mesa: 17.2+

    You can easily find out what you've got by running:

    sudo apt-get install phoronix-test-suite
    phoronix-test-suite system-info
    fglrx is dead and replaced in newer OS versions with an open source RadeonSi/RADV stack.

  17. #42
    Kickstarter Alpha Nomad fura's Avatar
    Join Date
    Feb 2016
    Location
    Budapest
    Posts
    438
    Post Thanks / Like
    Yeah, the problem with getting the latest of all the software components was that my card was not supported by the new driver...

    But I have an RX480 now, and everything works smooth and fine.
    I made screenshots: http://imgur.com/a/D1FM7 \o/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •