Results 1 to 4 of 4

Thread: [MEDIUM PRIORITY][v 0.9.1.0] FPS drops after long traveling

  1. #1
    Kickstarter Wreck Nomad Harrison's Avatar
    Join Date
    Jan 2016
    Location
    Earth
    Posts
    158
    Post Thanks / Like

    Exclamation [MEDIUM PRIORITY][v 0.9.1.0] FPS drops after long traveling

    Game Version: 0.9.1 beta
    OS: Windows 10 64-bit

    Detailed Description:
    Game on the new version of unity have weird glitch with fps drops, when I travel on very long distances. I didn't noticed this glitch, when played on the old versions. Don't know why it is causing, but, maybe, game "forgot" unload some data?

    Any additional information:


    Log: https://www.dropbox.com/s/swmw09zgz8...t_log.txt?dl=0

    Oh, I forgot to say. Maybe it depends, because I play on the old map (planet)? My game started from version 0.8.x ..

  2. #2
    Developer
    Join Date
    Feb 2016
    Posts
    352
    Post Thanks / Like
    Hello Harrison,

    Playing an old save should not have an impact on performance. Do you have similar experience with different saves?
    Most FPS drops is caused by physics, the new Unity handles physics different way and there might be also some differences in rendering and memory management. We'll take a look at the profiler, I hope it tell us what eats the CPU time.

  3. #3
    Kickstarter Wreck Nomad Harrison's Avatar
    Join Date
    Jan 2016
    Location
    Earth
    Posts
    158
    Post Thanks / Like
    Hello martinsustek. Yes, I have similar issue in my sandbox game. In one small area I have a lot of physic debris and vehicles. In first time, when I go out from this area on the long distance (just tested my hover), fps drops at 15-19 (after this I have not tested more).

    Then I started a new game, built small helicopter and fly on the long distance - fps was stable. I noticed that this glitch causing, when you discover or build a lot various buildings.

    Oh. And one important thing. After save / loading - fps will stable again. (if you didn't noticed on my video)

    Thank you!

    upd

    Here is performance test in sandbox. P.S. (recording takes ~5-10 frames) In the end of the video, I lost ~ 10 fps. Not very obviously (because with recording my fps jumps, but I may use SSD for record, if you want more clear results). For the strong results, I need play around 1 hr to get very low fps (in case, that I will travel).

    Last edited by Harrison; 01-08-2018 at 05:48 PM.

  4. #4
    Member BCP_Labs_YT's Avatar
    Join Date
    Apr 2018
    Location
    BC Canada
    Posts
    177
    Post Thanks / Like
    I've noticed that power lines seem to always be loaded. A few km away and you can still see them

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •