Results 1 to 10 of 10

Thread: 0.9.1.0 [LOW PRIORITY] Rotating conveyor

  1. #1
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like

    0.9.1.0 [LOW PRIORITY] Rotating conveyor

    When designing a new caterpillar track with conveyors and rotating plate, I came across this bug, the conveyor track hangs of a construction and the conveyor is rotating on a conveyor to conveyor connection.



    Save files:
    main.db

    save_14.db

  2. #2
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Are those conveyors on the same grid?
    If you remove a conveyor segment, close to the bottom right on the picture, will the T-shape conveyor fall or will stay?

    The rotating joints, as you know, create sub-grids. You cannot connect the conveyors extending from a rotating joint to anything else.
    Depending on how you want to mitigate forces, you can move that gap to the middle of the conveyor segment or to remove the rotating plate to prevent collisions.
    At this moment small collisions may occur on that place where the two sub-grids touch each other if the physics will allow a small wobble for whatever reason.

  3. #3
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like
    Yes, I built it top to bottom hanging from the construction pole.
    Now I can remove 15 blocks down, starting from the t-section mid picture and 18 blocks up from the t-section before it falls!?



    In this second picture the conveyors are still hanging on and not falling. If I remove the rotating plate at the top of the picture it will fall.



    I have no collisions in this design, besides of the collisions within the rotating plate itself. So something weird is going on.

  4. #4
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    We wanted so much to get ropes in the game and now you find that there are some, but are invisible
    It is a cool track design.
    I will look at the save you uploaded if you don't mind. You played in Unity 2018.2 or in the .1 version?

  5. #5
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like
    Still in 2018.1 I think, my game didn't download the 0.9.1.1 hotfix.

  6. #6
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    That is good, people have problems
    Even Steam screenshots are not visible anymore
    Here I colored the grids and sub-grids (not all of them). With red I marked the faulty sub-grid. I do not know how you managed to get the other behavior, the "invisible rope" one.
    If you can reproduce, maybe you can upload a video.
    _20180715133629_1.jpg

    - - - Updated - - -

    I applied the colors by editing the save. In between the red blocks there is that small sub-grid made by the rotating plate and the conveyor block (both visually and in the save file)
    I tried to understand the order how you placed the blocks. We have sometime glitches where a block is placed in a different position when the surface is moving. And it ends up partly in the air, shifted away from the grid.
    So I thought that one possible explanation would be that the lower red T-conveyor somehow connected to the upper red T-conveyor.
    But the order how the blocks are placed in the save file do not always show the order of placement.
    Maybe the order in the save is not always the order how blocks were placed. At least not in your file.

    Anyway, the "invisible rope" usecase would have been more interesting to see and I have no idea what to do to trigger that behavior.

  7. #7
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like
    Quote Originally Posted by Menzagitat View Post
    We have sometime glitches where a block is placed in a different position when the surface is moving. And it ends up partly in the air, shifted away from the grid.
    This happens sometimes to me in other builds, but surface isn't moving but the character is, in the microsecond that you click to build and your cursor moves snapping it to an other position.

    I got the invisible rope when you start removing 17 blocks, starting with the white one in the middle and moving up.

  8. #8
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Here I managed to get a weird behavior too, a different one:

    The very white "conveyor six-section" is part of the red grid too but that block is located in the save file after the small 2-block grid which is separating it.

    - - - Updated - - -

    I succeeded to reproduce the rope effect
    In my video I stopped removing the next rotating joint because I knew from a previous try that the structure will fall.
    That is the 18th block which you also didn't removed.

    - - - Updated - - -

    In conclusion, there are two bugs in this report:
    • The locked rotating joints and locked hinges do not activate the physics of the sub-grids when are deconstructed.
    • The grid marked with red color is broken in two

    And the interesting "invisible rope" side effect shown in the video below
    Last edited by Menzagitat; 15-07-2018 at 05:52 PM.

  9. #9
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like

  10. #10
    QA Lead (Craneballs)
    Join Date
    Aug 2016
    Posts
    219
    Post Thanks / Like
    Very interesting one! Great finding

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •