Results 1 to 14 of 14

Thread: Large structures in a different location after chunk reload and in stasis chamber

  1. #1
    Member BCP_Labs_YT's Avatar
    Join Date
    Apr 2018
    Location
    BC Canada
    Posts
    177
    Post Thanks / Like

    [LOW PRIORITY] Large structures in a different location after chunk reload and in stasis chamber

    im working on a project that is currently 80m high by about 150m that has been moving on me when i sleep and when i return to the location. it first sank down about 10m so i started digging it out to keep working on it. i did a save and then left the area and came back to it floating 20m up
    https://steamcommunity.com/sharedfil...?id=1369493303

    it does have a "few" hover pads. im not sure if that could be something to do with it but ive had past experience with my hover base sinking into the ground last year. i did also have a few ghosting issues as well, could see it but not touch it but could feel it a few meters over

    here is my save http://s000.tinyupload.com/index.php...48611844077863

    i was able to replant it but im not sure where it will be for you
    maybe new unity will help with this?
    Last edited by BCP_Labs_YT; 24-04-2018 at 07:21 PM.

  2. #2
    Member BCP_Labs_YT's Avatar
    Join Date
    Apr 2018
    Location
    BC Canada
    Posts
    177
    Post Thanks / Like
    upon loading and a quick nap to morning this happened
    https://youtu.be/wlnECv0NoPA

  3. #3
    QA Lead (Craneballs)
    Join Date
    Aug 2016
    Posts
    219
    Post Thanks / Like
    What The...I've never seen that before... we will definitely look at your save. Thanks !!

  4. #4
    Member BCP_Labs_YT's Avatar
    Join Date
    Apr 2018
    Location
    BC Canada
    Posts
    177
    Post Thanks / Like
    youre welcome. would you believe me if i told you this wasnt the first time ive seen this?

  5. #5
    Member BCP_Labs_YT's Avatar
    Join Date
    Apr 2018
    Location
    BC Canada
    Posts
    177
    Post Thanks / Like

  6. #6
    Senior Member DaFuzz's Avatar
    Join Date
    Jun 2017
    Posts
    251
    Post Thanks / Like
    Hiya guys.

    I've tried to reproduce what BCP had with my base, but unfortunately it didn't work.



    While I finished the movie and prepared for this post, I started to wonder about a few things.
    My entire base is grounded all over the size of the base, so the centre of mass of my base is firmly grounded.
    As I could see in the video of BCP, he grounded his huge craft in one single point in the ground, so probably the centre of mass indicator is floating above the ground far away of the point where it is grounded.

    So I assume that the physics go somewhat nutty when you enter the statis chamber that is not located the same grid.
    I do believe I read somewhere that someone else was having issues with the stasis chamber as well.

    I am wondered however, does this jump also appear if you build the stasis chamber to the grid that you are building?
    Why on earth would someone spent all his time in life being a little bit creative, when you can go all the way?

  7. #7
    Member BCP_Labs_YT's Avatar
    Join Date
    Apr 2018
    Location
    BC Canada
    Posts
    177
    Post Thanks / Like
    well originally it was planted at both ends. i still think it has to do with hover pads because that is really the only time ive seen this. had this happen with my hover base that slowly got eaten up by the land

  8. #8
    Senior Member
    Join Date
    Apr 2018
    Posts
    303
    Post Thanks / Like
    I'm inclined to think there's something glitchy/buggy about hover pads.
    I've built a couple hovers in my current world and they work great.
    Tried to build another, and it just sits on the ground.
    Tried flipping the pads in case I'd installed them as vacuum pads instead, no change. They've just become inert pads.

    So you may be on to something thinking this issue is related to hover pads.

  9. #9
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Quote Originally Posted by BCP_Labs_YT View Post
    youre welcome. would you believe me if i told you this wasnt the first time ive seen this?
    Developers know already that you have seen this:
    https://forum.planet-nomads.com/thre...ll=1#post12840

    This bug is duplicate with
    https://forum.planet-nomads.com/thre...r-loading-base

    The problem is that the collider is loaded in a different position. There are two ways to notice this, with huge structures:

    • if you load the game the texture stays separated by the collider causing the ghost effect. The player is sliding on the invisible collider.
    • if you return to the chunk the texture jumps to the collider but the object is in the wrong position

    We discussed this also here:
    https://forum.planet-nomads.com/thre...ew-finding-%29

    Developers said:

    Quote Originally Posted by martinsustek View Post
    Hi guys,
    We are still making builds with the 5.4 version of Unity. I've tried the same save in game built with newer 2017.3 version of Unity, and that bug wasn't there. So it might be some kind of old bug in Unity.
    ...
    We are currently working on some incompatibility fixes and hope we will be able to use new Unity to make builds soon.
    - - - Updated - - -

    Usually happens with huge structures which are not grounded, big vehicles or where the player removed the connecting part to the ground or the ground itself which was keeping the building in grounded state.
    But some players have the ghost effect even if the building is grounded.
    https://steamcommunity.com/workshop/...69163406170836

  10. #10
    QA Lead (Craneballs)
    Join Date
    Aug 2016
    Posts
    219
    Post Thanks / Like
    Quote Originally Posted by BCP_Labs_YT View Post
    upon loading and a quick nap to morning this happened
    https://youtu.be/wlnECv0NoPA
    I think we fixed it. It will be in next update.

  11. #11
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Quote Originally Posted by Goose View Post
    I think we fixed it. It will be in next update.
    What was the solution?
    Will this fix the sliding on surfaces too?

  12. #12
    Developer
    Join Date
    Feb 2016
    Posts
    352
    Post Thanks / Like
    It is related to freezing/unfreezeing objects when you move away/load game/time warp during sleep. When multiple freezes occurred at once, original speed/rotation was rewritten by the latter one, and on un-freeze (like during end of time warp) there were undefined values stored that caused physics to cause big movement in one frame. I've added some management of freezing which ensures right values to be used when unfreezing.

    I am not sure if this will help with sliding. It's probably not related.

  13. #13
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Before the big movement happened, the hitbox and the texture of the object were not in the same place and I was sliding on that invisible surface:
    https://forum.planet-nomads.com/thre...ll=1#post16288

    Once the object was unfrozen, the texture jumped to the hitbox.

    I encountered sliding on grounded buildings too and I was thinking that maybe the hitbox is just a little bit shifted from the texture.
    Also I noticed somebody else how after using the stasis chamber, the sliding stopped:
    https://www.youtube.com/watch?v=b5dcEjLwqrM&t=229

    And sliding used to happen last year too...

    - - - Updated - - -

    Here I found the link to the last year thread:
    https://steamcommunity.com/app/50405...86297693048242
    Quote Originally Posted by Old-gamer
    I also found a workaround (that only temporarily works) to the vehicle moon-walking on the rails. If I jump into a Stasis Chamber and heal (allowing time to pass), and then exit, all the problematic moon-walking (both myself and the rail-vehicle) comes to a rest. Unfortunately, getting into the rail-vehicle and driving it again on the rails, re-triggers all the moon-walking.
    He used to love helping you find the bugs, but he left upset when you didn't communicated anymore for one whole month, and you left a big discussion about a stasis chamber balancing to unfold.

  14. #14
    Senior Member
    Join Date
    Apr 2018
    Posts
    303
    Post Thanks / Like
    Oh how weird is that... just watched the video in the first link and I've never encountered anything like that... but then, I've never build a hanging roadway half a mile up, or a little two-wheeler to try to perch on it.

    Perhaps the closest things I've experienced anything like this have to do with the little flier my mobile base carts around on its back sometimes shifting its position without my noticing, and then going through some very strange bouncing when I launch that has on a few occasions caused me to end up upside down, but that's about it, and flipping my little flier over isn't a big deal - I've gotten quite good at it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •