Results 1 to 6 of 6

Thread: Moving 2k from base and back resulted in mobile base merged with hangar

  1. #1
    Member
    Join Date
    Sep 2017
    Posts
    11
    Post Thanks / Like

    Angry Moving 2k from base and back resulted in mobile base merged with hangar

    It merged with the hangar where it was parked and this made the frame rate to goes down to 2FPS.
    Now I cannot play anymore. even if I load a save where I'm still away from the base, when I reach it the same thing happen again...

    VERY FRUSTRATING!! All my work, hundred hours and I cannot play anymore!! First my Alpha base became a "ghost", not interactible anymore, I cannot play with it anymore, now this so I lost another of my bases... Tell me what to do?!? Is it wrong to continue with your "old" world when there is an update?!? Shall I start new every time you release a build!?!? That would be very bad and I would not feel much in the mood of playing Planet Nomads anymore untill it's stable enough...

    Please fix! attached the saves: https://mega.nz/#!XFonEbQD!vdRDGSN4ZB9TWYuAWiFQn53rXicygKmidW1t2BA JakI


  2. #2
    Developer
    Join Date
    Feb 2016
    Posts
    352
    Post Thanks / Like
    Hi warpengine,

    I can confirm, that bug in your saves appears also on my machine. In "seti" save, there is a vehicle wrongly rotated and stuck inside hangar walls. We don't have a fix for this issue yet. It is probably caused by low precision of coordinates used internally to represent game objects. When you save&load game or move away of objects, positions gets "rounded" to nearest 32 bit floating point number. This introduces small error, but physics calculations on tightly packed vehicle in small hangar could lead to big problems because of butterfly effect.

    I've tried to move your vehicle outside the hangar by hand and it somehow helped, so here is the modified save - https://mega.nz/#!Y3p0iJrI!6yj9LY0cW...j2krFIQzBD-tuA. Unfortunatelly, your vehicle is unable to move because of wheels not connected to electricity, which could point to some other error during saving. I feel really sorry about this, we have this hard to reproduce save bug, which we are still trying to fix. All I can recommend you now is do a lot of saving to different save slots and try to keep your buildings in reasonable distance. I feel really sorry about this. We do our best to fix it as soon as possible.

  3. #3
    Member
    Join Date
    Sep 2017
    Posts
    11
    Post Thanks / Like
    Dear martinsustek,

    Thank you very much for your reply and for the effort in fixing my saves, much appreciated.
    I will reload the save and try to resize my hangar, the big problem here was the 2fps which I could not work with, if now frame rate is again fine I can of course rebuild or fix whatever is broken, I'm not afraid of that neither I'm upset for that. Only the 2fps really made me cry.
    I've my first base in that save which is a ghost now, did you by chance had a look to that too? Do you have any update on that bug?

    Thanks again and Merry Christmas to all the team!

  4. #4
    Developer
    Join Date
    Feb 2016
    Posts
    352
    Post Thanks / Like
    The low FPS was probably caused by abnormal physics oscilations. There might be something else that caused it but as I recall, FPS got better after I loaded modified save.

    Speaking about ghost base, we've tried your save in Unity Editor on two different computers and it was exactly how you described it. Sorry that we didn't respond, but we are still scrathing our heads. We could go through the wall while looking at the collider which was supposed to stop you. We've checked every setting on those colliders and still cannot tell you, why they does not work. It's strange mystery. I hope we'll find solution soon.

    Thank you again for your patience and wish you a Merry Christmas too!

  5. #5
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Quote Originally Posted by martinsustek View Post
    Hi warpengine,
    ... We don't have a fix for this issue yet. It is probably caused by low precision of coordinates used internally to represent game objects. When you save&load game or move away of objects, positions gets "rounded" to nearest 32 bit floating point number. This introduces small error, but physics calculations on tightly packed vehicle in small hangar could lead to big problems because of butterfly effect.
    ...
    Any progress with the investigation? When is this problem going to be fixed?

  6. #6
    Senior Member
    Join Date
    Aug 2017
    Posts
    629
    Post Thanks / Like
    Quote Originally Posted by martinsustek View Post
    [...]
    Speaking about ghost base, we've tried your save in Unity Editor on two different computers and it was exactly how you described it. Sorry that we didn't respond, but we are still scrathing our heads. We could go through the wall while looking at the collider which was supposed to stop you. We've checked every setting on those colliders and still cannot tell you, why they does not work. It's strange mystery. I hope we'll find solution soon.
    [...]
    https://forum.planet-nomads.com/thre...-HIGH-PRIORITY

    https://forum.planet-nomads.com/thre...-Solid-Surface

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •