Results 1 to 18 of 18

Thread: [Acknowledged] Player sliding on floor

  1. #1
    Member
    Join Date
    Aug 2017
    Posts
    101
    Post Thanks / Like

    Exclamation [Acknowledged] Player sliding on floor

    I haven't had time to play lately so when I loaded the program this morning, my player started sliding. Not fast, just slow like the wind pushing a toy sailboat in a puddle.
    It doesn't happen on the ground, just on the base floor.
    I use a keyboard, and not a controller so I don't think it's a configuration issue and it had to happen in the last week or so.

    It does stop after a bit and it's a random direction. Between that and the head bob, the game just became weird.
    Last edited by GaryP156; 04-10-2017 at 12:44 PM.

  2. #2
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like
    Noticed it to, haven't had the time to test it. Happened after last patch. Wanted to rule out some things at my end. I'm building a tower haven't fallen off yet.

  3. #3
    Member
    Join Date
    Aug 2017
    Posts
    101
    Post Thanks / Like
    I've slid off the roof while setting my beacon at least twice. I thought it was my rig. Glad someone else saw this.

  4. #4
    Member Maslostroj (Daniel)'s Avatar
    Join Date
    Jun 2015
    Posts
    899
    Post Thanks / Like
    It does seem to be connected with the new way physics is calculated, which was necessary for the hovercrafts. If I remember correctly it happened with the old physics occasionally too, but seems to be more prominent now.
    "Well, I thought. This is how the world works. All energy flows according to the whims of the Great Magnet. What a fool I was to defy him."
    -Raoul Duke

  5. #5
    Senior Member Vrmithrax's Avatar
    Join Date
    Sep 2016
    Location
    Oregon
    Posts
    465
    Post Thanks / Like
    Any chance we could have our player boots just act a bit like low powered mag boots when they are touching a block component of any kind? It would prevent sliding on any metal surface, could also help the issue of being unable to stand on a vehicle without sliding too.

  6. #6
    Member
    Join Date
    Aug 2017
    Location
    The Netherlands
    Posts
    81
    Post Thanks / Like
    I noticed today that i was always sliding away from south pole, and that i had points in my base where i didn't slide. After sleeping in stasis chamber the sliding was gone. This was around 19:00 GMT +1:00.

  7. #7
    Member
    Join Date
    Aug 2017
    Posts
    101
    Post Thanks / Like
    After more testing I have places in my base where I slide and places I do not. Weird.
    I'm thinking the player character needs to be disconnected from the main physics, and this way I won't trip over a tiny bush and I can place a base block on the ground and step up onto it without jumping.

  8. #8
    Member
    Join Date
    Aug 2017
    Posts
    101
    Post Thanks / Like
    Any plans on a possible fix for this in today's update?

  9. #9
    Member Kwon's Avatar
    Join Date
    Sep 2017
    Location
    GER
    Posts
    75
    Post Thanks / Like
    Still sliding.
    Also, as mentioned above, sleeping long enough helps.
    For me, the sliding occurs almost every time after driving in a vehicle for a while.

  10. #10
    Member
    Join Date
    Aug 2017
    Posts
    101
    Post Thanks / Like
    Quote Originally Posted by Kwon View Post
    Still sliding.
    Also, as mentioned above, sleeping long enough helps.
    For me, the sliding occurs almost every time after driving in a vehicle for a while.
    Sounds like motion sickness to me. I get that.

    Seriously, can this be up there on the list. It leaves the player with a weird feeling.

  11. #11
    Member
    Join Date
    Sep 2017
    Location
    New Hampshire, USA
    Posts
    89
    Post Thanks / Like
    Version: 0.7.6
    OS: Ubuntu 14.04 LTS Kernel 3.13.0.123 generic 64bit
    Repeatability: Every Time:

    Description: Confirming what others are seeing, additional details.

    * Direction of slide always seems to be away from point where Nomad spawns.
    * Speed seems to be about .1m/s roughly timing sliding away from beacon.
    * Has only happened to me in 0.7.6 but did not start until two or three days ago. I think I had 0.7.6 for almost a week before it started.
    * Sleep in stasis chamber for 8 hours stops the sliding.
    * Does not happen on grass.
    * Does not happen on sections of my base built prior to the first time it happened.
    * Does not happen when new foundation piece is added to old section of base.
    * Does happen in sections of my base built since it first occurred.
    * Does happen when new foundation piece is added to sections of base built since it first occurred.

    Hope this helps.

    Log and save files (From my base disappearing thread): https://mega.nz/#!Qro11a6Q!xqRxAVBRr...vByCXsFTj3lBl8

    Regards,
    Sam

    *(UPDATE) After completely rebuilding my base the sliding has stopped as of this mornings session. (10-15-2017)
    Last edited by Agamemnon; 15-10-2017 at 06:32 PM. Reason: Updated Information

  12. #12
    Member
    Join Date
    Aug 2017
    Posts
    101
    Post Thanks / Like
    After the last update today, this is still an issue. Any chance of fixing this soon? It messes with my head.

  13. #13
    Member
    Join Date
    Nov 2017
    Posts
    1
    Post Thanks / Like
    I did not face this issue until today's update. I concur with the above observations.

  14. #14
    Member SsgDoc's Avatar
    Join Date
    Nov 2017
    Location
    Texas
    Posts
    3
    Post Thanks / Like
    Noticed sliding on ground today also 24-11-17 as stated from
    Agamemnon not on grass but on base foundations im a slow slider

  15. #15
    Kickstarter Alpha Nomad
    Join Date
    Aug 2016
    Posts
    229
    Post Thanks / Like
    Maybe related: many machines in by base were unusable or only accessible from certain positions. For example my printer would not open from one side, only a small part on the side would allow me to open the window. A switchboard was completely unusable, I could not open the radial menu or connect some other switchboard to it. This was also fixed by sleeping in stasis.
    100% linux gaming

  16. #16
    Member
    Join Date
    Jul 2017
    Location
    UK
    Posts
    184
    Post Thanks / Like
    Quote Originally Posted by GaryP156 View Post
    Sounds like motion sickness to me. I get that.

    Seriously, can this be up there on the list. It leaves the player with a weird feeling.
    I've noticed this lack of grip issue before when trying to build atop the vehicle, it's not an illusion from the player, you slide a bit if there's any gradient.

  17. #17
    Member bigstep70's Avatar
    Join Date
    Dec 2017
    Location
    Somewhere on a Random Gen World
    Posts
    35
    Post Thanks / Like
    I too have noticed the "moonwalk" effect (i call it) and after a bit of testing/troubleshooting I think it is just a small calculation error in the spawn process that's not "locking" you into the world physics properly. (when you continue, never noticed it on a fresh game, yet)

    It happens more often when standing on my flyer (rotor power was off and the flyer was "pinned" to the ground, 99% level) but I have seen it happen right after placing a large foundation plate as well. (place plate, stand on plate, let the moon walking begin.)
    And as stated, it seems to emanate from your spawn point, like a reverse black hole, pushing you away from your "point of origin".

    My solution was to do a manual save and reload that save...poof fixed, every-time.
    It may sound like a PitA but hey 10-15 seconds of save/load vs. moon-walking all over the place.

    Don't get me wrong, I kindda liked MJ back in the day and did get into the whole 'break-dancing' thing as a kid... but I'll leave moon-walking to the pro's.
    Last edited by bigstep70; 17-02-2018 at 08:12 PM.
    "They say that if you play any Microsoft Windows CD backwards, you'll hear satan... that's nothing, play it forwards and it installs Windows."

  18. #18
    Member
    Join Date
    Jul 2017
    Location
    UK
    Posts
    184
    Post Thanks / Like
    Love that description in the initial post:
    "Not fast, just slow like the wind pushing a toy sailboat in a puddle." sorry, had to say that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •