Results 1 to 8 of 8

Thread: Sound issues

  1. #1
    Kickstarter Alpha Nomad
    Join Date
    Dec 2016
    Posts
    7
    Post Thanks / Like

    Sound issues

    Hello Nomads!

    I think this may be my first official post in here....

    Either way, I have a RODE-NT USB microphone I use for recording/streaming and my headphones are connected through that. When playing Planet Nomads recently, I lose sound output from the game as well as any other source in my computer (Discord, music from Spotify or general computer notifications). The only solution to sound is unplugging and plugging my mic back in. The other issue is that I also lose voice and cannot regain my voice capabilities without closing out the game.

    I have tested my microphone in different USB ports and I've also tested the headphones in different output jacks as well as testing the game by itself without streaming/recording on general desktop audio. Each test has netted the same results, I lose sound output and eventually have to close out the game to regain sound output.

    One particular instance was bad enough I had to completely restart my computer.

    Other games work just fine. My YouTube channel is primarly about Ark: Survival Evolved and I have zero issues recording/streaming with that or any other game. These issues only arise with Planet Nomads.


    General thoughts:
    After considering the situation, I realize it only began happening after Survival Mode was released and I've waited on a few updates since then to see if it would be fixed (i.e. a known bug). After consulting with a friend who is in the IT career field, he suggested it may be possible something in the games code is interfering with the computers ability to process which driver is supposed to be sending sound output. Since I run 2 monitors that can output sound and multiple audio outputs exist on my rig, its entirely possible there is something going on with the computer vs the game that conflicts with the audio drivers.

    Is this a known bug? Is this an isolated incident? I'd love to record more PN content and collaborate with Junkasaurus some more!

  2. #2
    Member Maslostroj (Daniel)'s Avatar
    Join Date
    Jun 2015
    Posts
    899
    Post Thanks / Like
    Hello L1ttle3agle, thanks for reporting that you are affected by this issue. It's a combination of a known bug that however only affects a very small percentage of people (up to 10 reported similar issue if I remember correctly) and we have not been able to reproduce it.

    What your IT friend suggests is most likely true, but unfortunately not that helpful. Unless you are willing to experiment a bit. Disable the other sound outputs in the Sound Mixer on Windows, play without the microphone connected, etc.

    The issue may or may not be connected with USB ports in general, as people reported keyboards getting disconnected in a similar fashion. Did you have any troubles with that too? Which keyboard do you use and what other USB devices do you have connected?

    And finally, although not sure we'll find something there. Can you send the game-log after the audio cuts out? As in: audio cuts-out > quit the game regularly and send the log file:

    To Find the LOG file:
    The main game log on Windows can be found in the PlanetNomads_Data folder as output_log.txt
    On OSX, ~/Library/Logs/Unity/Player.log
    On linux, ~/.config/unity3d/Craneballs/PlanetNomads/Player.log
    On Windows (the usual path) C:\Program Files (x86)\Steam\steamapps\common\Planet Nomads\PlanetNomads_Data\output_log.txt
    "Well, I thought. This is how the world works. All energy flows according to the whims of the Great Magnet. What a fool I was to defy him."
    -Raoul Duke

  3. #3
    Member Maslostroj (Daniel)'s Avatar
    Join Date
    Jun 2015
    Posts
    899
    Post Thanks / Like
    After a bit of googling, here are some other tips to try:

    1) DISABLE ALL PLAYBACK DEVICES except the one you use for sound by right clicking the sound icon on windows and choosing "playback devices". (from Overwatch)

    2) Try muting steam in the windows audio control panel. It worked for me. (Steam forum)

    3) Update the sound driver in your computer. Go to Device Manager. Right Click on the Sound Driver and update it. If it won't fix the problem, then uninstall it from the device manager and restart the computer. Windows will generate the driver.

    4) Are you using Discord?

    5) Maybe this article: http://www.makeuseof.com/tag/fix-intermittent-sound-problems-windows/

    6) Here are some suggestions too:
    https://www.sevenforums.com/gaming/1...gaming-2.html?

    7) And finally this article: http://www.pcgamer.com/the-most-frus...roblem-solved/
    Based on this tip: http://www.techsupportforum.com/foru...ml#post3401894
    "Well, I thought. This is how the world works. All energy flows according to the whims of the Great Magnet. What a fool I was to defy him."
    -Raoul Duke

  4. #4
    Kickstarter Alpha Nomad
    Join Date
    Dec 2016
    Posts
    7
    Post Thanks / Like
    Thanks for the responses Maslostroj!

    1 - I have every sound output device disabled in the audio manager.
    2 - I use a Razer Orbweaver and a Razer Blackwidow keyboard with a Logitech G600 mouse.
    3 - I read through the known bugs megathread and I had a feeling this MAY be connected to the USB issue.
    4 - My sound drivers are up to date as well as all drivers for all peripherals I use.
    5 - I have researched the same articles you linked
    6 - I have tested with my usual applications (such as Discord) and with absolutely nothing open outside of Steam and the game client itself.
    7 - where do you want the output log? Copied and pasted here?

  5. #5
    Member Maslostroj (Daniel)'s Avatar
    Join Date
    Jun 2015
    Posts
    899
    Post Thanks / Like
    Snap, sorry for forgetting to reply here sooner.

    Thanks for the details.

    7. Uploading the file anywhere on the net (Google Drive, Dropbox, etc.) and linking here will do the trick.

    Also another update for the USBs (if you haven't seen that already):
    http://steamcommunity.com/app/504050...1444323809199/
    "Well, I thought. This is how the world works. All energy flows according to the whims of the Great Magnet. What a fool I was to defy him."
    -Raoul Duke

  6. #6
    Kickstarter Alpha Nomad
    Join Date
    Dec 2016
    Posts
    7
    Post Thanks / Like
    I'm still having the issue. I just turned on the game and got perhaps 10 minutes in and lost connection to my microphone. My keyboard, mouse and Razer Orbweaver all still worked, but the connection to my RODE-NT USB microphone was lost. I REALLY REALLY REALLY want to create videos and stream this game. the game itself is beautiful, the development is amazing and the few minutes I played today were SOOOOO tantalizing! I wanted to play more, but I just can't disconnect and reconnect my microphone every 5-10 minutes :(

    EDIT: Also, I'm sorry for the VERY delayed response. I'm in the middle of losing my job in the USAF and I'm trying to plan my transition and eventual unemployment....

  7. #7
    Kickstarter Alpha Nomad
    Join Date
    Dec 2016
    Posts
    7
    Post Thanks / Like
    I may have narrowed it down a tad.....

    I've been playing for a solid 20+ minutes this morning (more testing to follow today) without losing sound or microphone. Here's what I did, and what I think is going on....

    The RODE-NT USB microphone has an audio output jack on it as well as the ability to increase gain (this is really helpful for me in games like PUBG where I can increase my sound without destroying my audiences ears. So, I normally have my headphones plugged into the microphone. This morning, I plugged my headphones directly into the back of my motherboard. So far the only issues I've experienced is on my end; the peripherals I have flashed in the USB devices and sort of disappeared for a second then came straight back. However, I lost only one device, my webcam. All others continued to work; mouse, keyboard, Razer Orbweaver and microphone. I can honestly play without my webcam if that's the only one that Planet Nomads wants to have adverse effects with after this change.

    What I think: There's something going on within the games code that gets the computers system confused as to what USB devices are. I can't quite pinpoint what it is exactly just yet though. I don't experience any game crashes, so there aren't crash reports to recover, either. I generally use my Keyboard as a USB hub, too, and it seems that typing with my keyboard has a tendency to cause this to happen, so there may be something about USB hubs that this games code doesn't like?

    I've been playing primarily indie games, early access or pe-alpha, for the past 2 years. This is the only game I've encountered that has this issue.....

  8. #8
    Developer
    Join Date
    Feb 2016
    Posts
    352
    Post Thanks / Like
    Hi L1ttle3agle,

    As we changed the way how we use USB/controllers a few months ago, could you please check if this bug still persists, or was it fixed by the way? Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •